CAUTION: Escrow.com has not been sending some (or all) transaction emails plus the “continue” button is gone

I was waiting for a wire transfer to arrive from a buyer for a transaction at Escrow.com. I hadn’t received the usual email from escrow.com (please log in into your account) so I thought that there was some problem with the banks or that buyer hadn’t put the correct transaction id on the wire transfer. So I logged in into my account to file a support ticket only to see that payment had arrived 2 days ago. I didn’t get any emails from escrow.com about this. I don’t have a spam filter so I couldn’t loose the email. I am not sure when this problem started and how widespread is. If you have pending transactions it’s a good idea to log into your account and not wait for the email to arrive. But I had another problem…

Escrow instructed me to transfer the domain name to the buyer:

Submit the domain name transfer to the Buyer

• Escrow.com has secured the Buyer’s payment.
• The domain name transfer process varies with each registrar. Please communicate with your Buyer and the registrar directly to complete this process. Escrow.com does not transfer the domain
• After the transfer process has been started, please click the continue button to move the transaction forward and provide your Buyer the opportunity to mark the domain as received on the Escrow.com site.

 

Problem is that the continue button is nowhere to be found! I have tried to login with 3 different browsers but I can’t see it. I filed a support ticket about all these problems but the first reply was not helpful. I will not transfer the domain until all issues have been resolved.

Sold.Domains

About Konstantinos Zournas

Konstantinos studied Computer Engineering and Computer Science in London and lives in Athens, Greece. He loves domains and building websites. He is online since 1995, learned about html in 1996 and got into domains in 2002. He started the OnlineDomain.com blog in 2012.

6 comments

  1. Thanks for the update. That is a good note.

  2. Hello,
    Escrow.com did experience a delay in our incoming and outgoing emails on October 25. The delay has been rectified and all emails have been delivered-incoming and outgoing.
    The missing button on your transaction screen sounds like a possible bug. Escrow.com would love the opportunity to collect the transaction number, your operating system, and browser type and version as this information will assist our technical team in identifying and resolving the issue.
    Please feel free to contact me directly with that information.

    • I am missing one email from the 24th of October. I got one email from escrow today ok but not that old one.

      I am using Windows Vista with Internet Explorer and Opera. I also tested with my Samsung Galaxy tab using 2 different browsers.
      I never had any problems with the website before with either platforms.

  3. I completed another escrow.com transaction yesterday and everything (including the missing button) went fine. Everything has been fixed. Thanks

Leave a Reply

Your email address will not be published. Required fields are marked *

This site uses Akismet to reduce spam. Learn how your comment data is processed.